RelatedInstanceNodesSpecification Interface
Produces ECInstance nodes that are related to some source ECInstance. The source instance is determined by traversing the hierarchy upwards until an ECInstance node is encountered.
@see Related instance nodes specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
instanceFilter | string | undefined | Specifies an ECExpression for filtering | |
relationshipPaths | RepeatableRelationshipPathSpecification[] | Specifies a chain of relationship path specifications | |
specType | "RelatedInstanceNodes" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
doNotSort Inherited | boolean | undefined | ChildNodeSpecificationBase | Suppress sorting of nodes returned by this specification. |
groupByClass Inherited | boolean | undefined | DefaultGroupingPropertiesContainer | Controls whether returned instances should be grouped by ECClass. |
groupByLabel Inherited | boolean | undefined | DefaultGroupingPropertiesContainer | Controls whether returned instances should be grouped by label. |
hasChildren Inherited | "Always" | "Never" | "Unknown" | ChildNodeSpecificationBase | This attribute allows telling the engine that nodes created by this specification always or never have children. |
hideExpression Inherited | string | undefined | ChildNodeSpecificationBase | When specified ECExpression evaluates |
hideIfNoChildren Inherited | boolean | undefined | ChildNodeSpecificationBase | Specifies whether nodes created through this specification should be hidden if they have no child nodes. |
hideNodesInHierarchy Inherited | boolean | undefined | ChildNodeSpecificationBase | When true , instances nodes produced by this specification are omitted and their children appear one |
nestedRules Inherited | ChildNodeRule[] | undefined | ChildNodeSpecificationBase | Specifications of nested child node rules that |
priority Inherited | number | undefined | ChildNodeSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is |
relatedInstances Inherited | RelatedInstanceSpecification[] | undefined | ChildNodeSpecificationBase | Specifications of related instances that can be used |
suppressSimilarAncestorsCheck Inherited | boolean | undefined | ChildNodeSpecificationBase | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.