ChildNodeRule Interface
Child node rules are used to define child nodes in a hierarchy.
@see Child node rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
ruleType | "ChildNodes" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
condition | string | undefined | NavigationRuleBase | Defines a condition which needs to be met in order for the rule to be used. |
customizationRules | CustomizationRule[] | undefined | NavigationRuleBase | A list of customization rules that |
onlyIfNotHandled | boolean | undefined | NavigationRuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | number | undefined | NavigationRuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | RequiredSchemaSpecification[] | undefined | NavigationRuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
specifications | ChildNodeSpecification[] | undefined | NavigationRuleBase | A list of hierarchy specifications that define what nodes are going to be returned. |
stopFurtherProcessing | boolean | undefined | NavigationRuleBase | Stop processing rules that have lower priority. |
subConditions | SubCondition[] | undefined | NavigationRuleBase | A list of sub-rules which share placement attributes and |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.