NavigationRuleBase Interface
Base class for all NavigationRule implementations.
@see Hierarchies reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | string | undefined | Defines a condition which needs to be met in order for the rule to be used. | |
customizationRules | CustomizationRule[] | undefined | A list of customization rules that | |
specifications | ChildNodeSpecification[] | undefined | A list of hierarchy specifications that define what nodes are going to be returned. | |
stopFurtherProcessing | boolean | undefined | Stop processing rules that have lower priority. | |
subConditions | SubCondition[] | undefined | A list of sub-rules which share placement attributes and |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
ruleType Inherited | "RootNodes" | "ChildNodes" | "Content" | "ContentModifier" | "DefaultPropertyCategoryOverride" | "Grouping" | "PropertySorting" | "DisabledSorting" | "NodeArtifacts" | "InstanceLabelOverride" | "LabelOverride" | "CheckBox" | "ImageIdOverride" | "StyleOverride" | "ExtendedData" | RuleBase | Used for serializing to JSON. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.