RuleBase Interface
Base interface for all Rule implementations.
Properties
Name | Type | Description | |
---|---|---|---|
onlyIfNotHandled | boolean | undefined | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule | |
priority | number | undefined | Defines the order in which rules are handled, higher number means the rule is handled first. | |
requiredSchemas | RequiredSchemaSpecification[] | undefined | A list of ECSchema requirements that need to be met for the rule to be used. | |
ruleType | "RootNodes" | "ChildNodes" | "Content" | "ContentModifier" | "DefaultPropertyCategoryOverride" | "Grouping" | "PropertySorting" | "DisabledSorting" | "NodeArtifacts" | "InstanceLabelOverride" | "LabelOverride" | "CheckBox" | "ImageIdOverride" | "StyleOverride" | "ExtendedData" | Used for serializing to JSON. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.