ChildNodeSpecificationBase Interface
Base interface for all ChildNodeSpecification implementations.
@see Child node specifications reference documentation section
Properties
Name | Type | Description | |
---|---|---|---|
doNotSort | boolean | undefined | Suppress sorting of nodes returned by this specification. | |
hasChildren | "Always" | "Never" | "Unknown" | This attribute allows telling the engine that nodes created by this specification always or never have children. | |
hideExpression | string | undefined | When specified ECExpression evaluates | |
hideIfNoChildren | boolean | undefined | Specifies whether nodes created through this specification should be hidden if they have no child nodes. | |
hideNodesInHierarchy | boolean | undefined | When true , instances nodes produced by this specification are omitted and their children appear one |
|
nestedRules | ChildNodeRule[] | undefined | Specifications of nested child node rules that | |
priority | number | undefined | Controls the order in which specifications are handled — specification with higher priority value is | |
relatedInstances | RelatedInstanceSpecification[] | undefined | Specifications of related instances that can be used | |
specType | "RelatedInstanceNodes" | "InstanceNodesOfSpecificClasses" | "CustomQueryInstanceNodes" | "CustomNode" | Used for serializing to JSON. | |
suppressSimilarAncestorsCheck | boolean | undefined | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.