CustomNodeSpecification Interface
Returns a static custom-defined node that's not based on an ECInstance.
@see Custom node specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | string | undefined | Specifies the value of description property, which is a string that may | |
imageId | string | undefined | Specifies node's image ID. | |
label | string | Specifies node label. | |
specType | "CustomNode" | Used for serializing to JSON. | |
type | string | Specifies node type, which is assigned to node's key. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
doNotSort Inherited | boolean | undefined | ChildNodeSpecificationBase | Suppress sorting of nodes returned by this specification. |
hasChildren Inherited | "Always" | "Never" | "Unknown" | ChildNodeSpecificationBase | This attribute allows telling the engine that nodes created by this specification always or never have children. |
hideExpression Inherited | string | undefined | ChildNodeSpecificationBase | When specified ECExpression evaluates |
hideIfNoChildren Inherited | boolean | undefined | ChildNodeSpecificationBase | Specifies whether nodes created through this specification should be hidden if they have no child nodes. |
hideNodesInHierarchy Inherited | boolean | undefined | ChildNodeSpecificationBase | When true , instances nodes produced by this specification are omitted and their children appear one |
nestedRules Inherited | ChildNodeRule[] | undefined | ChildNodeSpecificationBase | Specifications of nested child node rules that |
priority Inherited | number | undefined | ChildNodeSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is |
relatedInstances Inherited | RelatedInstanceSpecification[] | undefined | ChildNodeSpecificationBase | Specifications of related instances that can be used |
suppressSimilarAncestorsCheck Inherited | boolean | undefined | ChildNodeSpecificationBase | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.