ContentModifier Interface
Content modifiers are used to modify how instances of specified ECClasses are displayed in content which is produced using content rules. They do not produce any content by themselves.
@see Content modifier rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applyOnNestedContent | boolean | undefined | Specifies whether calculatedProperties and |
|
class | SingleSchemaClassSpecification | undefined | Specification of ECClass whose content should be modified. | |
ruleType | "ContentModifier" | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties Inherited | CalculatedPropertiesSpecification[] | undefined | ContentModifiersList | Specifications of calculated properties whose values are |
onlyIfNotHandled Inherited | boolean | undefined | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
propertyCategories Inherited | PropertyCategorySpecification[] | undefined | ContentModifiersList | Specifications for custom categories. |
propertyOverrides Inherited | PropertySpecification[] | undefined | ContentModifiersList | Specifications for various property overrides that allow customizing property display. |
relatedProperties Inherited | RelatedPropertiesSpecification[] | undefined | ContentModifiersList | Specifications of related properties which are |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.