LinearlyReferencedFromToLocation Class
Concrete multi-aspect class carrying 'from-to' linearly-referenced positions along a Linear-Element.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: LinearlyReferencedFromToLocationAspectProps, iModel: IModelDb): LinearlyReferencedFromToLocation | ||
create(iModel: IModelDb, locatedElementId: string, from: DistanceExpression, to: DistanceExpression, fromReferentId?: string, toReferentId?: string): LinearlyReferencedFromToLocation Static | ||
insert(iModel: IModelDb, locatedElementId: string, from: DistanceExpression, to: DistanceExpression, fromReferentId?: string, toReferentId?: string): void Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(_referenceIds: EntityReferenceSet): void Protected Inherited | LinearlyReferencedLocation | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom?: boolean): void Inherited | LinearlyReferencedLocation | Call a function for each property of this Entity. |
getReferenceIds(): EntityReferenceSet Inherited | LinearlyReferencedLocation | Get the set of this entity's entity references, EntityReferenceSet. |
toJSON(): ElementAspectProps Inherited | LinearlyReferencedLocation | Obtain the JSON representation of this Entity. |
is(otherClass: ): boolean Static Inherited | LinearlyReferencedLocation | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnAspectIdArg): void Protected Static Inherited | LinearlyReferencedLocation | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void Protected Static Inherited | LinearlyReferencedLocation | Called after an ElementAspect was deleted. |
onInsert(arg: OnAspectPropsArg): void Protected Static Inherited | LinearlyReferencedLocation | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void Protected Static Inherited | LinearlyReferencedLocation | Called after a new ElementAspect was inserted. |
onUpdate(arg: OnAspectPropsArg): void Protected Static Inherited | LinearlyReferencedLocation | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void Protected Static Inherited | LinearlyReferencedLocation | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
fromPosition | DistanceExpression | ||
fromPositionFromReferent | LinearlyReferencedFromPositionRefersToReferent | undefined | ||
toPosition | DistanceExpression | ||
toPositionFromReferent | LinearlyReferencedToPositionRefersToReferent | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | LinearlyReferencedLocation | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | LinearlyReferencedLocation | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | LinearlyReferencedLocation | The name of the BIS class associated with this class. |
element Inherited | RelatedElement | LinearlyReferencedLocation | |
id Inherited | string | LinearlyReferencedLocation | The Id of this Entity. |
iModel Inherited | IModelDb | LinearlyReferencedLocation | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | LinearlyReferencedLocation | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static Inherited | LinearlyReferencedLocation | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | LinearlyReferencedLocation | The name of the BIS Schema that defines this class |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.