PrimitiveArrayProperty Class

Extends

Methods

Name Description
constructor(ecClass: ECClass, name: string, primitiveType: PrimitiveTypePrimitiveType.Integer): PrimitiveArrayProperty    
toJSON(): PrimitiveArrayPropertyProps Save this PrimitiveArrayProperty's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
addCustomAttribute(customAttribute: CustomAttribute): void Protected Inherited ArrayPropertyMixin(PrimitiveProperty)  
fromJSON(primitivePropertyProps: PrimitivePropertyProps): Promise<void> Inherited ArrayPropertyMixin(PrimitiveProperty)  
fromJSON(propertyProps: PropertyProps): Promise<void> Inherited ArrayPropertyMixin(PrimitiveProperty)  
fromJSONSync(primitivePropertyProps: PrimitivePropertyProps): void Inherited ArrayPropertyMixin(PrimitiveProperty)  
fromJSONSync(propertyProps: PropertyProps): void Inherited ArrayPropertyMixin(PrimitiveProperty)  
getCategorySync(): undefined | PropertyCategory Inherited ArrayPropertyMixin(PrimitiveProperty)  
getCustomAttributes(): Promise<> Inherited ArrayPropertyMixin(PrimitiveProperty) Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited ArrayPropertyMixin(PrimitiveProperty) Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited ArrayPropertyMixin(PrimitiveProperty)  
isArray(): this is AnyArrayProperty Inherited ArrayPropertyMixin(PrimitiveProperty)  
isEnumeration(): this is AnyEnumerationProperty Inherited ArrayPropertyMixin(PrimitiveProperty)  
isNavigation(): this is NavigationProperty Inherited ArrayPropertyMixin(PrimitiveProperty)  
isPrimitive(): this is AnyPrimitiveProperty Inherited ArrayPropertyMixin(PrimitiveProperty)  
isStruct(): this is AnyStructProperty Inherited ArrayPropertyMixin(PrimitiveProperty)  
setName(name: ECName): void Protected Inherited ArrayPropertyMixin(PrimitiveProperty)  

Inherited properties

Name Type Inherited from Description
_category Protected Inherited LazyLoadedPropertyCategory | undefined ArrayPropertyMixin(PrimitiveProperty)  
_class Protected Inherited AnyClass ArrayPropertyMixin(PrimitiveProperty)  
_description Protected Inherited string | undefined ArrayPropertyMixin(PrimitiveProperty)  
_extendedTypeName Protected Inherited string | undefined ArrayPropertyMixin(PrimitiveProperty)  
_isReadOnly Protected Inherited boolean | undefined ArrayPropertyMixin(PrimitiveProperty)  
_kindOfQuantity Protected Inherited LazyLoadedKindOfQuantity | undefined ArrayPropertyMixin(PrimitiveProperty)  
_label Protected Inherited string | undefined ArrayPropertyMixin(PrimitiveProperty)  
_maxLength Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_maxOccurs Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_maxValue Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_minLength Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_minOccurs Protected Inherited number ArrayPropertyMixin(PrimitiveProperty)  
_minValue Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_name Protected Inherited ECName ArrayPropertyMixin(PrimitiveProperty)  
_priority Protected Inherited number | undefined ArrayPropertyMixin(PrimitiveProperty)  
_type Protected Inherited PropertyType ArrayPropertyMixin(PrimitiveProperty)  
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory ArrayPropertyMixin(PrimitiveProperty)  
class Accessor Inherited ReadOnly AnyClass ArrayPropertyMixin(PrimitiveProperty)  
customAttributes Accessor Inherited ReadOnly undefined | ArrayPropertyMixin(PrimitiveProperty)  
description Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(PrimitiveProperty)  
extendedTypeName Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(PrimitiveProperty)  
fullName Accessor Inherited ReadOnly string ArrayPropertyMixin(PrimitiveProperty) Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean ArrayPropertyMixin(PrimitiveProperty)  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity ArrayPropertyMixin(PrimitiveProperty)  
label Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(PrimitiveProperty)  
maxLength Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(PrimitiveProperty)  
maxOccurs Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(PrimitiveProperty)  
maxValue Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(PrimitiveProperty)  
minLength Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(PrimitiveProperty)  
minOccurs Accessor Inherited ReadOnly number ArrayPropertyMixin(PrimitiveProperty)  
minValue Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(PrimitiveProperty)  
name Accessor Inherited ReadOnly string ArrayPropertyMixin(PrimitiveProperty)  
primitiveType Accessor Inherited ReadOnly PrimitiveType ArrayPropertyMixin(PrimitiveProperty)  
priority Accessor Inherited ReadOnly number ArrayPropertyMixin(PrimitiveProperty)  
propertyType Accessor Inherited ReadOnly PropertyType ArrayPropertyMixin(PrimitiveProperty)  
schema Accessor Inherited ReadOnly Schema ArrayPropertyMixin(PrimitiveProperty) Returns the schema of the class holding the property.

Defined in

Last Updated: 14 November, 2024