Name |
Type |
Inherited from |
Description |
_category Protected Inherited |
LazyLoadedPropertyCategory | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_class Protected Inherited |
AnyClass |
ArrayPropertyMixin(EnumerationProperty) |
|
_description Protected Inherited |
string | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_enumeration Protected Inherited |
LazyLoadedEnumeration | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_extendedTypeName Protected Inherited |
string | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_isReadOnly Protected Inherited |
boolean | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_kindOfQuantity Protected Inherited |
LazyLoadedKindOfQuantity | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_label Protected Inherited |
string | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_maxLength Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_maxOccurs Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_maxValue Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_minLength Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_minOccurs Protected Inherited |
number |
ArrayPropertyMixin(EnumerationProperty) |
|
_minValue Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_name Protected Inherited |
ECName |
ArrayPropertyMixin(EnumerationProperty) |
|
_priority Protected Inherited |
number | undefined |
ArrayPropertyMixin(EnumerationProperty) |
|
_type Protected Inherited |
PropertyType |
ArrayPropertyMixin(EnumerationProperty) |
|
category Accessor Inherited ReadOnly |
undefined | LazyLoadedPropertyCategory |
ArrayPropertyMixin(EnumerationProperty) |
|
class Accessor Inherited ReadOnly |
AnyClass |
ArrayPropertyMixin(EnumerationProperty) |
|
customAttributes Accessor Inherited ReadOnly |
undefined | |
ArrayPropertyMixin(EnumerationProperty) |
|
description Accessor Inherited ReadOnly |
undefined | string |
ArrayPropertyMixin(EnumerationProperty) |
|
enumeration Accessor Inherited ReadOnly |
undefined | LazyLoadedEnumeration |
ArrayPropertyMixin(EnumerationProperty) |
|
extendedTypeName Accessor Inherited ReadOnly |
undefined | string |
ArrayPropertyMixin(EnumerationProperty) |
|
fullName Accessor Inherited ReadOnly |
string |
ArrayPropertyMixin(EnumerationProperty) |
Returns the name in the format 'ClassName.PropertyName'. |
isReadOnly Accessor Inherited ReadOnly |
boolean |
ArrayPropertyMixin(EnumerationProperty) |
|
kindOfQuantity Accessor Inherited ReadOnly |
undefined | LazyLoadedKindOfQuantity |
ArrayPropertyMixin(EnumerationProperty) |
|
label Accessor Inherited ReadOnly |
undefined | string |
ArrayPropertyMixin(EnumerationProperty) |
|
maxLength Accessor Inherited ReadOnly |
undefined | number |
ArrayPropertyMixin(EnumerationProperty) |
|
maxOccurs Accessor Inherited ReadOnly |
undefined | number |
ArrayPropertyMixin(EnumerationProperty) |
|
maxValue Accessor Inherited ReadOnly |
undefined | number |
ArrayPropertyMixin(EnumerationProperty) |
|
minLength Accessor Inherited ReadOnly |
undefined | number |
ArrayPropertyMixin(EnumerationProperty) |
|
minOccurs Accessor Inherited ReadOnly |
number |
ArrayPropertyMixin(EnumerationProperty) |
|
minValue Accessor Inherited ReadOnly |
undefined | number |
ArrayPropertyMixin(EnumerationProperty) |
|
name Accessor Inherited ReadOnly |
string |
ArrayPropertyMixin(EnumerationProperty) |
|
priority Accessor Inherited ReadOnly |
number |
ArrayPropertyMixin(EnumerationProperty) |
|
propertyType Accessor Inherited ReadOnly |
PropertyType |
ArrayPropertyMixin(EnumerationProperty) |
|
schema Accessor Inherited ReadOnly |
Schema |
ArrayPropertyMixin(EnumerationProperty) |
Returns the schema of the class holding the property. |