EnumerationPropertyProps Interface

Extends

Properties

Name Type Description
typeName Readonly string    

Inherited properties

Name Type Inherited from Description
category Readonly Inherited string | undefined PrimitiveOrEnumPropertyBaseProps  
customAttributes Readonly Inherited { T }[] | undefined PrimitiveOrEnumPropertyBaseProps  
description Readonly Inherited string | undefined PrimitiveOrEnumPropertyBaseProps  
extendedTypeName Readonly Inherited string | undefined PrimitiveOrEnumPropertyBaseProps  
inherited Readonly Inherited boolean | undefined PrimitiveOrEnumPropertyBaseProps  
isReadOnly Readonly Inherited boolean | undefined PrimitiveOrEnumPropertyBaseProps  
kindOfQuantity Readonly Inherited string | undefined PrimitiveOrEnumPropertyBaseProps  
label Readonly Inherited string | undefined PrimitiveOrEnumPropertyBaseProps  
maxLength Readonly Inherited number | undefined PrimitiveOrEnumPropertyBaseProps  
maxValue Readonly Inherited number | undefined PrimitiveOrEnumPropertyBaseProps  
minLength Readonly Inherited number | undefined PrimitiveOrEnumPropertyBaseProps  
minValue Readonly Inherited number | undefined PrimitiveOrEnumPropertyBaseProps  
name Readonly Inherited string PrimitiveOrEnumPropertyBaseProps  
priority Readonly Inherited number | undefined PrimitiveOrEnumPropertyBaseProps  
type Readonly Inherited string PrimitiveOrEnumPropertyBaseProps  

Defined in

Last Updated: 14 November, 2024