SchemaXmlStringLocater Class
A SchemaLocator implementation for locating and deserializing EC Schemas from XML strings loaded in memory.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(): SchemaXmlStringLocater | ||
getSchema<T extends Schema>(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | T> | Attempts to retrieve a Schema with the given SchemaKey by searching the configured | |
getSchemaInfo(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | SchemaInfo> | Gets the schema info which matches the provided SchemaKey. | |
getSchemaKey(schemaXml: string): SchemaKey | Constructs a SchemaKey based on the information in the Schema XML. | |
getSchemaSync<T extends Schema>(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): undefined | T | Attempts to retrieve a Schema with the given SchemaKey by searching the configured |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addSchemaString(schemaString: string): void Inherited | SchemaStringLocater | Adds a schema string used by this locator to locate and load Schemas. |
addSchemaStrings(schemaStrings: string[]): void Inherited | SchemaStringLocater | Adds schema strings used by this locator to find the |
compareSchemaKeyByVersion(lhs: StringSchemaKey, rhs: StringSchemaKey): number Inherited | SchemaStringLocater | Compares two Schema versions. |
findEligibleSchemaKeys(desiredKey: Readonly<SchemaKey>, matchType: SchemaMatchType): StringSchemaKey[] Protected Inherited | SchemaStringLocater | Attempts to find all Schema strings that match the desired SchemaKey. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
schemaStrings Inherited | string[] | SchemaStringLocater |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.