SchemaStringLocater Class
Abstract class to hold common/overlapping functionality between SchemaJsonStringLocater and SchemaXmlStringLocater
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): SchemaStringLocater | ||
addSchemaString(schemaString: string): void | Adds a schema string used by this locator to locate and load Schemas. | |
addSchemaStrings(schemaStrings: string[]): void | Adds schema strings used by this locator to find the | |
compareSchemaKeyByVersion(lhs: StringSchemaKey, rhs: StringSchemaKey): number | Compares two Schema versions. | |
findEligibleSchemaKeys(desiredKey: Readonly<SchemaKey>, matchType: SchemaMatchType): StringSchemaKey[] Protected | Attempts to find all Schema strings that match the desired SchemaKey. | |
getSchema<T extends Schema>(key: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | T> Abstract | ||
getSchemaKey(data: string): SchemaKey Protected Abstract |
Properties
Name | Type | Description | |
---|---|---|---|
schemaStrings | string[] |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.