ViewPose3d Class
The "pose" for a ViewState3d, including information about the view's Camera if it is enabled.
Extends
Methods
Name | Description | |
---|---|---|
constructor(view: ViewState3d): ViewPose3d | Construct a pose from the specified 3d view. | |
equal(other: ViewPose): boolean | See ViewPose.equal. | |
equalState(view: ViewState): boolean | See equalState. |
Properties
Name | Type | Description | |
---|---|---|---|
camera Readonly | Camera | The camera parameters of the view. | |
extents Readonly | Vector3d | See extents. | |
origin Readonly | Point3d | See ViewPose.origin. | |
rotation Readonly | Matrix3d | See rotation. | |
target Accessor ReadOnly | Point3d | See ViewPose.target. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
cameraOn | boolean | ViewPose | True if the camera is enabled. |
center Accessor ReadOnly | Point3d | ViewPose | Computes the center of the viewed volume. |
undoTime | BeTimePoint | undefined | ViewPose | The time at which this pose was created, if it was saved into a Viewport's undo stack. |
zVec Accessor ReadOnly | Vector3d | ViewPose | Computes the Z vector of the rotation matrix. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.