PlanarClipMaskState Class
The State of Planar Clip Mask applied to a reality model or background map. Handles loading models and their associated tiles for models that are used by masks but may not be otherwise loaded or displayed.
Methods
Name | Description | |
---|---|---|
discloseTileTrees(trees: DisclosedTileTreeSet): void | ||
getPlanarClipMaskSymbologyOverrides(context: SceneContext, featureSymbologySource: FeatureSymbology.Source): undefined | FeatureSymbology.Overrides | ||
getTileTrees(context: SceneContext, classifiedModelId: string, maskRange: Range3d): undefined | TileTreeReference[] | ||
create(settings: PlanarClipMaskSettings): PlanarClipMaskState Static | ||
fromJSON(props: PlanarClipMaskProps): PlanarClipMaskState Static |
Properties
Name | Type | Description | |
---|---|---|---|
settings Readonly | PlanarClipMaskSettings | ||
usingViewportOverrides Accessor ReadOnly | boolean |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.