ViewClipDecoration Class
A pickable decoration managed by ViewClipDecorationProvider used to visualize a view's clip and present modification handles. This class is public to facilitate customization of view clip events by type or selected controls.
@see ViewClipDecorationProvider
Extends
Methods
Name | Description | |
---|---|---|
constructor(_clipView: ScreenViewport, _clipEventHandler?: ViewClipEventHandler): ViewClipDecoration | ||
clearControls(): void Protected | ||
createControls(): Promise<boolean> Protected | The provider is responsible for checking if modification by controls is valid. | |
decorate(context: DecorateContext): void | Sub-classes should override to display the pickable graphics for their controls. | |
doClipPlaneClear(index: number): boolean | ||
doClipPlaneNegate(index: number): boolean | ||
doClipPlaneOrientView(index: number): boolean | ||
doClipShapeSetZExtents(extents: Range1d): boolean | ||
getControlIndex(id: string): number | ||
getDecorationToolTip(hit: HitDetail): Promise<string | HTMLElement> | ||
isClipShapeAlignedWithWorldUp(extents?: Range1d): boolean | ||
modifyControls(hit: HitDetail, _ev: BeButtonEvent): Promise<boolean> Protected | A provider can install an InputCollector to support interactive modification. | |
onManipulatorEvent(eventType: EditManipulator.EventType): void | ||
onRightClick(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled> Protected | Sub-classes can override to present a menu for a right click on a handle. | |
onTouchTap(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled> Protected | Sub-classes can override to respond to a touch tap on a handle. | |
onViewClose(vp: ScreenViewport): void | ||
stop(): void Protected | Call to clear this handle provider. | |
testDecorationHit(id: string): boolean | ||
updateDecorationListener(_add: boolean): void Protected | Register for decorate event to start displaying control handles. | |
clear(): void Static | ||
create(vp: ScreenViewport, clipEventHandler?: ViewClipEventHandler): undefined | string Static | ||
get(vp: ScreenViewport): undefined | ViewClipDecoration Static | ||
toggle(vp: ScreenViewport, clipEventHandler?: ViewClipEventHandler): Promise<undefined | string> Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onDecorationButtonEvent(hit: HitDetail, ev: BeButtonEvent): Promise<EventHandled> Inherited | EditManipulator.HandleProvider | Event raised by a PrimitiveTool that supports handle providers to allow a pickable decoration to respond to being located. |
onDoubleClick(_hit: HitDetail, _ev: BeButtonEvent): Promise<EventHandled> Protected Inherited | EditManipulator.HandleProvider | Sub-classes can override to perform some operation for a double click on a handle. |
onManipulatorToolEvent(_tool: Tool, event: ManipulatorToolEvent): void Inherited | EditManipulator.HandleProvider | Event raised by a PrimitiveTool that supports handle providers. |
onSelectionChanged(ev: SelectionSetEvent): void Inherited | EditManipulator.HandleProvider | Event raised by SelectionSet when the active selection changes. |
updateControls(): Promise<void> Protected Inherited | EditManipulator.HandleProvider |
Properties
Name | Type | Description | |
---|---|---|---|
_clipEventHandler Protected | ViewClipEventHandler | undefined | ||
_clipView Protected | ScreenViewport | ||
clipId Accessor ReadOnly | undefined | string | ||
clipPlaneSet Accessor ReadOnly | undefined | ConvexClipPlaneSet | ||
clipShape Accessor ReadOnly | undefined | ClipShape |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isActive Protected Inherited | boolean | EditManipulator.HandleProvider | |
_removeDecorationListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
_removeManipulatorToolListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
_removeSelectionListener Protected Inherited | () => void | undefined | EditManipulator.HandleProvider | |
iModel Inherited | IModelConnection | EditManipulator.HandleProvider |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.