MaterialTextureMappingProps Interface
Describes how to map a RenderTexture's image to the surfaces to which a RenderMaterial is applied.
@see textureMapping.
Properties
Name | Type | Description | |
---|---|---|---|
constantLodProps | TextureMapping.ConstantLodParamProps | undefined | Parameters for constant LOD mapping mode. | |
mode | TextureMapping.Mode | undefined | The mode controlling how the image is mapped onto the surface. | |
normalMapParams | NormalMapParams | undefined | The parameters describing a normal map to use either in place of or in addition to the texture. | |
texture | RenderTexture | The texture from which the image is obtained. | |
transform | TextureMapping.Trans2x3 | undefined | A 2x3 matrix for computing the UV coordinates. | |
useConstantLod | boolean | undefined | True if want to use constant LOD texture mapping for the surface texture. | |
weight | number | undefined | The ratio by which the color sampled from the texture image is mixed with the surface's or material's diffuse color. |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.