TextureMapping.Trans2x3 Class

A 2x3 matrix for mapping a texture image to a surface.

Methods

Name Description
constructor(m00: number1, m01: number0, originX: number0, m10: number0, m11: number1, originY: number0): TextureMapping.Trans2x3 Construct from the two rows of the matrix:  
compare(other: TextureMapping.Trans2x3): number An OrderedComparator that compares this Trans2x3 against other.  

Properties

Name Type Description
identity Static Readonly TextureMapping.Trans2x3 An immutable 2x3 identity matrix.  
transform Readonly Transform The 3x4 transform produced from the 2x3 matrix.  

Defined in

Last Updated: 28 October, 2024