NativeApp Class
The frontend of a native application
@see Native Applications
Methods
Name | Description | |
---|---|---|
constructor(): NativeApp | ||
callNativeHost<T extends AsyncMethodsOf<NativeAppFunctions>>(methodName: T, ...args: Parameters<>): Promise<PromiseReturnType<>> Static | ||
checkInternetConnectivity(): Promise<InternetConnectivityStatus> Static | determine whether the app currently has internet connectivity, if known | |
closeStorage(storage: Storage, deleteStorage: booleanfalse): Promise<void> Static | Close a Storage and optionally delete it. | |
deleteBriefcase(fileName: string): Promise<void> Static | Delete an existing briefcase | |
getBriefcaseFileName(props: BriefcaseProps): Promise<string> Static | Get the full path filename for a briefcase within the briefcase cache | |
getCachedBriefcases(iModelId?: string): Promise<LocalBriefcaseProps[]> Static | Get a list of all briefcase files held in the local briefcase cache directory | |
getStorageNames(): Promise<string[]> Static | Get the list of existing Storages on the local disk. | |
openStorage(name: string): Promise<Storage> Static | Open a Storage. | |
requestDownloadBriefcase(iTwinId: string, iModelId: string, downloadOptions: DownloadBriefcaseOptions, asOf?: IModelVersion): Promise<BriefcaseDownloader> Static | ||
requestDownloadBriefcase(iTwinId: string, iModelId: string, downloadOptions: DownloadBriefcaseOptions, asOf?: IModelVersion, progress?: ): Promise<BriefcaseDownloader> Static | Deprecated |
Properties
Name | Type | Description | |
---|---|---|---|
isValid Accessor Static ReadOnly | boolean | ||
nativeAppIpc Static | PickAsyncMethods<NativeAppFunctions> | A Proxy to call one of the NativeAppFunctions functions via IPC. | |
onInternetConnectivityChanged Static | BeEvent<(status: InternetConnectivityStatus) => void> | event called when internet connectivity changes, if known |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.