IModelVersion Class
Option to specify the version of the iModel to be acquired and used
Methods
Name | Description | |
---|---|---|
getAsOfChangeSet(): undefined | string | Returns the last change set id to be applied to the iModel | |
getName(): undefined | string | Returns the name of the version if this describes a named version. | |
toJSON(): IModelVersionProps | ||
asOfChangeSet(changesetId: string): IModelVersion Static | Describes a version of the iModel by the last change set that needs | |
first(): IModelVersion Static | Describes the first version of the iModel | |
fromJSON(json: IModelVersionProps): IModelVersion Static | Creates a version from an IModelVersionProps | |
latest(): IModelVersion Static | Describes the latest version of the iModel | |
named(versionName: string): IModelVersion Static | Describes a version of the iModel with the specified version name |
Properties
Name | Type | Description | |
---|---|---|---|
isFirst Accessor ReadOnly | boolean | Returns true if this describes the first version | |
isLatest Accessor ReadOnly | boolean | Returns true if this describes the latest version |
Defined in
- core/common/src/IModelVersion.ts Line 23
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.