BriefcaseDownloader Interface
Manages the download of a briefcase
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseId Readonly | number | Id of the briefcase being downloaded | |
downloadPromise Readonly | Promise<void> | Promise that resolves when the download completes. | |
fileName Readonly | string | the name of the local file for the briefcase | |
requestCancel Readonly | () => Promise<boolean> | Request cancellation of the download |
Defined in
- core/common/src/BriefcaseTypes.ts Line 184
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.