DynamicGraphicsRequestProps Interface
Wire format describing a request to produce graphics in "iMdl" format for a single geometry stream.
@see - DynamicGraphicsRequest2dProps and DynamicGraphicsRequest3dProps.
- ElementGraphicsRequestProps for more details.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
categoryId Readonly | string | The category to which the geometry belongs. | |
elementId Readonly | string | undefined | If specified, tools will recognize the generated graphics as being associated with this element. | |
geometry Readonly | JsonGeometryStream | FlatBufferGeometryStream | The geometry from which to generate the graphics. | |
modelId Readonly | string | undefined | If specified, tools will recognize the generated graphics as being associated with this model. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clipToProjectExtents Readonly Inherited | boolean | undefined | GraphicsRequestProps | If true, the element's graphics will be clipped against the iModel's project extents. |
id Readonly Inherited | string | GraphicsRequestProps | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. |
location Readonly Inherited | TransformProps | undefined | GraphicsRequestProps | Transform from element graphics to world coordinates. |
omitEdges Readonly Inherited | boolean | undefined | GraphicsRequestProps | If true, surface edges will be omitted from the graphics. |
quantizePositions Inherited | boolean | undefined | GraphicsRequestProps | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. |
sectionCut Readonly Inherited | string | undefined | GraphicsRequestProps | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut |
toleranceLog10 Readonly Inherited | number | GraphicsRequestProps | Log10 of the chord tolerance with which to stroke the element's geometry. |
useAbsolutePositions Inherited | boolean | undefined | GraphicsRequestProps | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.