DynamicGraphicsRequest2dProps Interface
Wire format describing a request to produce graphics in "iMdl" format for a 2d geometry stream.
@see ElementGraphicsRequestProps for more details.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
placement Readonly | Omit<Placement2dProps, "bbox"> | The origin and rotation of the geometry. | |
type Readonly | "2d" | Specifies the geometry is 2d. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categoryId Readonly Inherited | string | DynamicGraphicsRequestProps | The category to which the geometry belongs. |
clipToProjectExtents Readonly Inherited | boolean | undefined | DynamicGraphicsRequestProps | If true, the element's graphics will be clipped against the iModel's project extents. |
elementId Readonly Inherited | string | undefined | DynamicGraphicsRequestProps | If specified, tools will recognize the generated graphics as being associated with this element. |
geometry Readonly Inherited | JsonGeometryStream | FlatBufferGeometryStream | DynamicGraphicsRequestProps | The geometry from which to generate the graphics. |
id Readonly Inherited | string | DynamicGraphicsRequestProps | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. |
location Readonly Inherited | TransformProps | undefined | DynamicGraphicsRequestProps | Transform from element graphics to world coordinates. |
modelId Readonly Inherited | string | undefined | DynamicGraphicsRequestProps | If specified, tools will recognize the generated graphics as being associated with this model. |
omitEdges Readonly Inherited | boolean | undefined | DynamicGraphicsRequestProps | If true, surface edges will be omitted from the graphics. |
quantizePositions Inherited | boolean | undefined | DynamicGraphicsRequestProps | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. |
sectionCut Readonly Inherited | string | undefined | DynamicGraphicsRequestProps | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut |
toleranceLog10 Readonly Inherited | number | DynamicGraphicsRequestProps | Log10 of the chord tolerance with which to stroke the element's geometry. |
useAbsolutePositions Inherited | boolean | undefined | DynamicGraphicsRequestProps | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.