GraphicsRequestProps Interface
Wire format describing properties common to PersistentGraphicsRequestProps and DynamicGraphicsRequestProps.
@see ElementGraphicsRequestProps for more details.
Properties
Name | Type | Description | |
---|---|---|---|
clipToProjectExtents Readonly | boolean | undefined | If true, the element's graphics will be clipped against the iModel's project extents. | |
id Readonly | string | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. | |
location Readonly | TransformProps | undefined | Transform from element graphics to world coordinates. | |
omitEdges Readonly | boolean | undefined | If true, surface edges will be omitted from the graphics. | |
quantizePositions | boolean | undefined | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. | |
sectionCut Readonly | string | undefined | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut | |
toleranceLog10 Readonly | number | Log10 of the chord tolerance with which to stroke the element's geometry. | |
useAbsolutePositions | boolean | undefined | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.