RenderSchedule.TransformEntry Class
A timeline entry that applies rotation, scaling, and/or translation to the affected geometry.
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: RenderSchedule.TransformEntryProps): RenderSchedule.TransformEntry | ||
compareTo(other: RenderSchedule.TransformEntry): number | ||
toJSON(): RenderSchedule.TransformEntryProps |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equals(other: RenderSchedule.TimelineEntry): boolean | RenderSchedule.TimelineEntry |
Properties
Name | Type | Description | |
---|---|---|---|
components Readonly | RenderSchedule.TransformComponents | undefined | The transform represented as a rotation about a pivot point followed by a translation. | |
value Readonly | Readonly<Transform> | The transform matrix to be applied to the geometry, used only if RenderSchedule.TransformEntry.components is not defined. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
interpolation Readonly | RenderSchedule.Interpolation | RenderSchedule.TimelineEntry | How to interpolate from this entry to the next entry in the timeline. |
time Readonly | number | RenderSchedule.TimelineEntry | The time point in seconds in the Unix Epoch. |
Defined in
- core/common/src/RenderSchedule.ts Line 313
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.