RepositoryModel Class

The singleton container of repository-related information elements.

Extends

Methods

Name Description
constructor(props: ModelProps, iModel: IModelDb): RepositoryModel Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited DefinitionModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited DefinitionModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited DefinitionModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited DefinitionModel  
getReferenceIds(): EntityReferenceSet Inherited DefinitionModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited DefinitionModel Get a set of JSON user properties by namespace
insert(): string Inherited DefinitionModel Insert this Model in the iModel
removeUserProperties(nameSpace: string): void Inherited DefinitionModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited DefinitionModel  
setUserProperties(nameSpace: string, value: any): void Inherited DefinitionModel Change a set of user JSON properties of this Element by namespace.
toJSON(): ModelProps Inherited DefinitionModel Obtain the JSON representation of this Entity.
update(): void Inherited DefinitionModel Update this Model in the iModel.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string Static Inherited DefinitionModel Insert a DefinitionPartition and a DefinitionModel that sub-models it.
is(otherClass: ): boolean Static Inherited DefinitionModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited DefinitionModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited DefinitionModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DefinitionModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DefinitionModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited DefinitionModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited DefinitionModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DefinitionModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited DefinitionModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited DefinitionModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited DefinitionModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited DefinitionModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited DefinitionModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string DefinitionModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string DefinitionModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string DefinitionModel The name of the BIS class associated with this class.
id Inherited string DefinitionModel The Id of this Entity.
iModel Inherited IModelDb DefinitionModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" DefinitionModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean DefinitionModel  
isTemplate Inherited boolean DefinitionModel  
jsonProperties Readonly Inherited { T } DefinitionModel  
modeledElement Readonly Inherited RelatedElement DefinitionModel  
name Readonly Inherited string DefinitionModel  
parentModel Readonly Inherited string DefinitionModel  
schema Static Inherited DefinitionModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string DefinitionModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024