InformationRecordModel Class
A container for persisting Information Record Elements
@see InformationRecordPartition
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ModelProps, iModel: IModelDb): InformationRecordModel Protected | ||
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string Static | Insert a InformationRecordPartition and a InformationRecordModel that sub-models it. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited | InformationModel | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void Inherited | InformationModel | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited | InformationModel | Call a function for each property of this Entity. |
getJsonProperty(name: string): any Inherited | InformationModel | |
getReferenceIds(): EntityReferenceSet Inherited | InformationModel | Get the set of this entity's entity references, EntityReferenceSet. |
getUserProperties(namespace: string): any Inherited | InformationModel | Get a set of JSON user properties by namespace |
insert(): string Inherited | InformationModel | Insert this Model in the iModel |
removeUserProperties(nameSpace: string): void Inherited | InformationModel | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void Inherited | InformationModel | |
setUserProperties(nameSpace: string, value: any): void Inherited | InformationModel | Change a set of user JSON properties of this Element by namespace. |
toJSON(): ModelProps Inherited | InformationModel | Obtain the JSON representation of this Entity. |
update(): void Inherited | InformationModel | Update this Model in the iModel. |
is(otherClass: ): boolean Static Inherited | InformationModel | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void Protected Static Inherited | InformationModel | Called before a Model is deleted. |
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited | InformationModel | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited | InformationModel | Called after an Element in an instance of a Model of this class has been deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited | InformationModel | Called when an Element in an instance of a Model of this class is about to be deleted. |
onInsert(arg: OnModelPropsArg): void Protected Static Inherited | InformationModel | Called before a new Model is inserted. |
onInserted(_arg: OnModelIdArg): void Protected Static Inherited | InformationModel | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited | InformationModel | Called after an Element has been inserted into an instance of a Model of this class. |
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited | InformationModel | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited | InformationModel | Called before a Model is updated. |
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited | InformationModel | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited | InformationModel | Called after an Element in an instance of a Model of this class has been updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited | InformationModel | Called when an Element in an instance of a Model of this class is about to be updated. |
Properties
Name | Type | Description | |
---|---|---|---|
className Accessor Static ReadOnly | string | The name of the BIS class associated with this class. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor Inherited ReadOnly | string | InformationModel | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor Static Inherited ReadOnly | string | InformationModel | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor Inherited ReadOnly | string | InformationModel | The name of the BIS class associated with this class. |
id Inherited | string | InformationModel | The Id of this Entity. |
iModel Inherited | IModelDb | InformationModel | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly Inherited | "true" | InformationModel | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate Inherited | boolean | InformationModel | |
isTemplate Inherited | boolean | InformationModel | |
jsonProperties Readonly Inherited | { T } | InformationModel | |
modeledElement Readonly Inherited | RelatedElement | InformationModel | |
name Readonly Inherited | string | InformationModel | |
parentModel Readonly Inherited | string | InformationModel | |
schema Static Inherited | InformationModel | The Schema that defines this class. | |
schemaName Accessor Inherited ReadOnly | string | InformationModel | The name of the BIS Schema that defines this class |
Defined in
- core/backend/src/Model.ts Line 472
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.