IModelDb.Views Class
The collection of views in an IModelDb.
Methods
Name | Description | |
---|---|---|
accessViewStore(args: { accessLevel?: BlobContainer.RequestAccessLevel, props?: CloudSqlite.ContainerProps }): Promise<ViewStore.CloudAccess> | ||
getThumbnail(viewDefinitionId: string): undefined | ThumbnailProps | Get the thumbnail for a view. | |
getViewStateData(viewDefinitionId: string, options?: ViewStateLoadProps): ViewStateProps | Deprecated | |
getViewStateProps(viewDefinitionId: string, options?: ViewStateLoadProps): Promise<ViewStateProps> | Obtain a ViewStateProps for a ViewDefinition specified by ViewIdString. | |
iterateViews(params: ViewQueryParams, callback: (view: ViewDefinition) => boolean): boolean | Iterate all ViewDefinitions matching the supplied query. | |
queryViewDefinitionProps(className: string"BisCore.ViewDefinition", limit: numberIModelDb.defaultLimit, offset: number0, wantPrivate: booleanfalse): ViewDefinitionProps[] | Query for the array of ViewDefinitionProps of the specified class and matching the specified IsPrivate setting. | |
saveDefaultViewStore(arg: CloudSqlite.ContainerProps): void | ||
saveThumbnail(viewDefinitionId: string, thumbnail: ThumbnailProps): number | Save a thumbnail for a view. | |
setDefaultViewId(viewId: string): void | Set the default view property the iModel. | Deprecated |
Properties
Name | Type | Description | |
---|---|---|---|
defaultQueryParams Static Readonly | ViewQueryParams | Default parameters for iterating/querying ViewDefinitions. | |
hasViewStore Accessor ReadOnly | boolean | ||
viewStore Accessor | ViewStore.CloudAccess |
Defined in
- core/backend/src/IModelDb.ts Line 2238
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.