ViewQueryParams Interface
Parameters for performing a query on ViewDefinition classes.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
wantPrivate | boolean | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
bindings | object | any[] | EntityQueryParams | Bindings for parameterized values. |
from | string | undefined | EntityQueryParams | The sql className, in the form "Schema.ClassName", of the class to search. |
limit | number | undefined | EntityQueryParams | Optional "LIMIT" clause to limit the number of rows returned. |
offset | number | undefined | EntityQueryParams | Optional "OFFSET" clause. |
only | boolean | undefined | EntityQueryParams | Set to true to limit results to not include sub-classes of "from" class |
orderBy | string | undefined | EntityQueryParams | Optional "ORDERBY" clause to sort results. |
where | string | undefined | EntityQueryParams | Optional "WHERE" clause to filter entities. |
Defined in
- core/common/src/ViewProps.ts Line 154
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.