RoleElement Class

A real world entity is modeled as a Role Element when a set of external circumstances define an important role (one that is worth tracking) that is not intrinsic to the entity playing the role. For example, a person can play the role of a teacher or a rock can play the role of a boundary marker.

Extends

Extended by

Methods

Name Description
constructor(props: ElementProps, iModel: IModelDb): RoleElement Protected    

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected Inherited Element Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited Element Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited Element Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited Element Call a function for each property of this Entity.
Element Get the class metadata for this element.
getDisplayLabel(): string Inherited Element Get a display label for this Element.
getJsonProperty(nameSpace: string): any Inherited Element Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set Inherited Element Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet Inherited Element Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] Inherited Element Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any Inherited Element Get a set of JSON user properties by namespace
insert(): string Inherited Element Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void Inherited Element Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void Inherited Element  
setUserProperties(nameSpace: string, value: any): void Inherited Element Change a set of user JSON properties of this Element by namespace.
toJSON(): ElementProps Inherited Element Obtain the JSON representation of this Entity.
update(): void Inherited Element Update this Element in the iModel.
is(otherClass: ): boolean Static Inherited Element return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Element Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void Protected Static Inherited Element Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void Protected Static Inherited Element Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void Protected Static Inherited Element Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void Protected Static Inherited Element Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void Protected Static Inherited Element Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void Protected Static Inherited Element Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void Protected Static Inherited Element Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void Protected Static Inherited Element Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void Protected Static Inherited Element Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void Protected Static Inherited Element Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void Protected Static Inherited Element Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void Protected Static Inherited Element Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void Protected Static Inherited Element Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void Protected Static Inherited Element Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void Protected Static Inherited Element Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void Protected Static Inherited Element Called after an Element was updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string Element Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string Element Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string Element The name of the BIS class associated with this class.
code Inherited Code Element The Code for this element
federationGuid Inherited string | undefined Element A FederationGuid assigned to this element by some other federated database
id Inherited string Element The Id of this Entity.
iModel Inherited IModelDb Element The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" Element An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly Inherited { T } Element Optional json properties of this element.
model Readonly Inherited string Element The ModelId of the Model containing this element
parent Inherited RelatedElement | undefined Element The parent element, if present, of this element.
requiredReferenceKeys Static Readonly Inherited ReadonlyArray Element A required reference is an element that had to be inserted before this element could have been inserted.
schema Static Inherited Element The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string Element The name of the BIS Schema that defines this class
userLabel Inherited string | undefined Element A user-assigned label for this element.

Defined in

Last Updated: 14 November, 2024