GroupModel Class

A generic container for BisCore:GroupInformationElement instances.

Extends

Methods

Name Description
constructor(props: ModelProps, iModel: IModelDb): GroupModel    
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string Static Insert a GroupInformationPartition and a GroupModel that breaks it down.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected Inherited GroupInformationModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void Inherited GroupInformationModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited GroupInformationModel Call a function for each property of this Entity.
getJsonProperty(name: string): any Inherited GroupInformationModel  
getReferenceIds(): EntityReferenceSet Inherited GroupInformationModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any Inherited GroupInformationModel Get a set of JSON user properties by namespace
insert(): string Inherited GroupInformationModel Insert this Model in the iModel
removeUserProperties(nameSpace: string): void Inherited GroupInformationModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void Inherited GroupInformationModel  
setUserProperties(nameSpace: string, value: any): void Inherited GroupInformationModel Change a set of user JSON properties of this Element by namespace.
toJSON(): ModelProps Inherited GroupInformationModel Obtain the JSON representation of this Entity.
update(): void Inherited GroupInformationModel Update this Model in the iModel.
is(otherClass: ): boolean Static Inherited GroupInformationModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void Protected Static Inherited GroupInformationModel Called before a Model is deleted.
onDeleted(_arg: OnModelIdArg): void Protected Static Inherited GroupInformationModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GroupInformationModel Called after an Element in an instance of a Model of this class has been deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GroupInformationModel Called when an Element in an instance of a Model of this class is about to be deleted.
onInsert(arg: OnModelPropsArg): void Protected Static Inherited GroupInformationModel Called before a new Model is inserted.
onInserted(_arg: OnModelIdArg): void Protected Static Inherited GroupInformationModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GroupInformationModel Called after an Element has been inserted into an instance of a Model of this class.
onInsertElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GroupInformationModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void Protected Static Inherited GroupInformationModel Called before a Model is updated.
onUpdated(_arg: OnModelIdArg): void Protected Static Inherited GroupInformationModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void Protected Static Inherited GroupInformationModel Called after an Element in an instance of a Model of this class has been updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void Protected Static Inherited GroupInformationModel Called when an Element in an instance of a Model of this class is about to be updated.

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string GroupInformationModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string GroupInformationModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string GroupInformationModel The name of the BIS class associated with this class.
id Inherited string GroupInformationModel The Id of this Entity.
iModel Inherited IModelDb GroupInformationModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" GroupInformationModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate Inherited boolean GroupInformationModel  
isTemplate Inherited boolean GroupInformationModel  
jsonProperties Readonly Inherited { T } GroupInformationModel  
modeledElement Readonly Inherited RelatedElement GroupInformationModel  
name Readonly Inherited string GroupInformationModel  
parentModel Readonly Inherited string GroupInformationModel  
schema Static Inherited GroupInformationModel The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string GroupInformationModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024