TypeConverter Class
Type Converter base class.
Extended by
- BooleanTypeConverter
- CompositeTypeConverter
- DateTimeTypeConverterBase
- EnumTypeConverter
- HexadecimalTypeConverter
- NavigationPropertyTypeConverter
- NumericTypeConverterBase
- BasePointTypeConverter
- StringTypeConverter
Implements
Methods
Name | Description | |
---|---|---|
constructor(): TypeConverter | ||
convertFromString(_value: string): undefined | ConvertedPrimitives.Value | Promise<Value | undefined> | Converts a string to a primitive value |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> | Converts a string with a property record to a property value | |
convertFromStringWithOptions(value: string, _options?: [key: string]: any): undefined | ConvertedPrimitives.Value | Promise<Value | undefined> | Default implementation just calls convertFromString with no options |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Primitives.Value): string | Promise<string> | Converts a value associated with a property description to a string | |
convertToString(value?: Primitives.Value): string | Promise<string> | Converts a primitive value to a string | |
convertToStringWithOptions(value?: Primitives.Value, _options?: [key: string]: any): string | Promise<string> | Default implementation just calls convertToString with no options | |
isEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean | Determines if two primitive values are equal | |
isNotEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean | Determines if two primitive values are not equal | |
isNotNull(value: Primitives.Value): boolean | Determines if a primitive value is not null or not undefined | |
isNull(value: Primitives.Value): boolean | Determines if a primitive value is null or undefined | |
sortCompare(valueA: Primitives.Value, valueB: Primitives.Value, _ignoreCase?: boolean): number Abstract | Sort function for two primitive values |
Properties
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.