StringTypeConverter Class
String Type Converter.
Extends
Implements
Methods
Name |
Description |
|
constructor(): StringTypeConverter |
|
|
contains(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string contains another string |
|
convertFromString(value: string): string |
Converts a string to a primitive value |
|
convertToString(value?: string): string |
Converts a primitive value to a string |
|
doesNotContain(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string does not contain another string |
|
endsWith(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string ends with another string |
|
isContainedIn(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string is contained within another string |
|
isEmpty(valueA: string): boolean |
Determines if a string is empty |
|
isNotContainedIn(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string is not contained within another string |
|
isNotEmpty(valueA: string): boolean |
Determines if a string is not empty |
|
sortCompare(valueA: string, valueB: string, ignoreCase?: boolean): number |
Sort function for two primitive values |
|
startsWith(valueA: string, valueB: string, caseSensitive: boolean): boolean |
Determines if one string starts with another string |
|
Inherited methods
Properties
Name |
Type |
Description |
|
isStringType Accessor ReadOnly |
boolean |
Determines if the converter is for a string type |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
isBooleanType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a boolean type |
isLessGreaterType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a nullable type |
Defined in
Last Updated: 13 November, 2024