ChangedInstanceIds Class
Class for discovering modified elements between 2 versions of an iModel.
Methods
Name | Description | |
---|---|---|
constructor(db: IModelDb): ChangedInstanceIds | ||
addChange(change: ChangedECInstance): Promise<void> | Adds the provided ChangedECInstance to the appropriate set of changes by class type (codeSpec, model, element, aspect, or relationship) maintained by this instance of ChangedInstanceIds. | |
addCustomAspectChange(changeType: SqliteChangeOp, ids: Id64Arg): void | This method should only be called inside [IModelTransformer.addCustomChanges]. | |
addCustomElementChange(changeType: SqliteChangeOp, ids: Id64Arg): Promise<void> | This method should only be called inside addCustomChanges. | |
addCustomModelChange(changeType: SqliteChangeOp, ids: Id64Arg): Promise<void> | This method should only be called inside [IModelTransformer.addCustomChanges]. | |
initialize(opts: ChangedInstanceIdsInitOptions): Promise<undefined | ChangedInstanceIds> Static | Initializes a new ChangedInstanceIds object with information taken from a range of changesets. |
Properties
Name | Type | Description | |
---|---|---|---|
aspect | ChangedInstanceOps | ||
codeSpec | ChangedInstanceOps | ||
element | ChangedInstanceOps | ||
font | ChangedInstanceOps | ||
hasChanges Accessor ReadOnly | boolean | Checks if there are any changes. | |
model | ChangedInstanceOps | ||
relationship | ChangedInstanceOps |
Defined in
Last Updated: 06 March, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.