addCustomChanges MethodProtected
This will be called when transformer is called with argsForProcessChanges to process changes.
It will be executed after changes in changesets are populated into sourceDbChanges
and before data processing begins.
Remap table between the source and target iModels will be built at that time, meaning that functions like context.findTargetElementId will return meaningful results.
This function should be used to modify the sourceDbChanges
, if necessary, using add custom change
methods in ChangedInstanceIds, such as addCustomElementChange, addCustomModelChange and other.
addCustomChanges(_sourceDbChanges: ChangedInstanceIds): Promise<void>
@note Its expected that this function be overridden by a subclass of transformer if it needs to modify sourceDbChanges.
Parameter | Type | Description |
---|---|---|
_sourceDbChanges | ChangedInstanceIds |
Returns - Promise
Defined in
Last Updated: 06 March, 2025