StructArrayProperty Class

Extends

Methods

Name Description
constructor(ecClass: ECClass, name: string, type: StructClass): StructArrayProperty    

Inherited methods

Name Inherited from Description
addCustomAttribute(customAttribute: CustomAttribute): void Protected Inherited ArrayPropertyMixin(StructProperty)  
fromJSON(structPropertyProps: StructPropertyProps): Promise<void> Inherited ArrayPropertyMixin(StructProperty)  
fromJSON(propertyProps: PropertyProps): Promise<void> Inherited ArrayPropertyMixin(StructProperty)  
fromJSONSync(structPropertyProps: StructPropertyProps): void Inherited ArrayPropertyMixin(StructProperty)  
fromJSONSync(propertyProps: PropertyProps): void Inherited ArrayPropertyMixin(StructProperty)  
getCategorySync(): undefined | PropertyCategory Inherited ArrayPropertyMixin(StructProperty)  
getCustomAttributes(): Promise<> Inherited ArrayPropertyMixin(StructProperty) Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited ArrayPropertyMixin(StructProperty) Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited ArrayPropertyMixin(StructProperty)  
isArray(): this is AnyArrayProperty Inherited ArrayPropertyMixin(StructProperty)  
isEnumeration(): this is AnyEnumerationProperty Inherited ArrayPropertyMixin(StructProperty)  
isNavigation(): this is NavigationProperty Inherited ArrayPropertyMixin(StructProperty)  
isPrimitive(): this is AnyPrimitiveProperty Inherited ArrayPropertyMixin(StructProperty)  
isStruct(): this is AnyStructProperty Inherited ArrayPropertyMixin(StructProperty)  
setName(name: ECName): void Protected Inherited ArrayPropertyMixin(StructProperty)  
toJSON(): StructPropertyProps Inherited ArrayPropertyMixin(StructProperty)  
toJSON(): PropertyProps Inherited ArrayPropertyMixin(StructProperty) Save this Property's properties to an object for serializing to JSON.

Inherited properties

Name Type Inherited from Description
_category Protected Inherited LazyLoadedPropertyCategory | undefined ArrayPropertyMixin(StructProperty)  
_class Protected Inherited AnyClass ArrayPropertyMixin(StructProperty)  
_description Protected Inherited string | undefined ArrayPropertyMixin(StructProperty)  
_isReadOnly Protected Inherited boolean | undefined ArrayPropertyMixin(StructProperty)  
_kindOfQuantity Protected Inherited LazyLoadedKindOfQuantity | undefined ArrayPropertyMixin(StructProperty)  
_label Protected Inherited string | undefined ArrayPropertyMixin(StructProperty)  
_maxOccurs Protected Inherited number | undefined ArrayPropertyMixin(StructProperty)  
_minOccurs Protected Inherited number ArrayPropertyMixin(StructProperty)  
_name Protected Inherited ECName ArrayPropertyMixin(StructProperty)  
_priority Protected Inherited number | undefined ArrayPropertyMixin(StructProperty)  
_structClass Protected Inherited StructClass ArrayPropertyMixin(StructProperty)  
_type Protected Inherited PropertyType ArrayPropertyMixin(StructProperty)  
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory ArrayPropertyMixin(StructProperty)  
class Accessor Inherited ReadOnly AnyClass ArrayPropertyMixin(StructProperty)  
customAttributes Accessor Inherited ReadOnly undefined | ArrayPropertyMixin(StructProperty)  
description Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(StructProperty)  
fullName Accessor Inherited ReadOnly string ArrayPropertyMixin(StructProperty) Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean ArrayPropertyMixin(StructProperty)  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity ArrayPropertyMixin(StructProperty)  
label Accessor Inherited ReadOnly undefined | string ArrayPropertyMixin(StructProperty)  
maxOccurs Accessor Inherited ReadOnly undefined | number ArrayPropertyMixin(StructProperty)  
minOccurs Accessor Inherited ReadOnly number ArrayPropertyMixin(StructProperty)  
name Accessor Inherited ReadOnly string ArrayPropertyMixin(StructProperty)  
priority Accessor Inherited ReadOnly number ArrayPropertyMixin(StructProperty)  
propertyType Accessor Inherited ReadOnly PropertyType ArrayPropertyMixin(StructProperty)  
schema Accessor Inherited ReadOnly Schema ArrayPropertyMixin(StructProperty) Returns the schema of the class holding the property.
structClass Accessor Inherited ReadOnly StructClass ArrayPropertyMixin(StructProperty)  

Defined in

Last Updated: 14 November, 2024