Format Class
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited |
SchemaItem |
Indicates if the two SchemaItem objects are equal by comparing their respective key properties. |
parseFullName(fullName: string): [string, string] Static Inherited |
SchemaItem |
Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name |
Type |
Description |
|
_base Protected |
BaseFormat |
|
|
_units Protected |
[Unit | InvertedUnit, undefined | string][] | undefined |
|
|
decimalSeparator Accessor ReadOnly |
string |
|
|
formatTraits Accessor ReadOnly |
FormatTraits |
|
|
includeZero Accessor ReadOnly |
undefined | boolean |
|
|
minWidth Accessor ReadOnly |
undefined | number |
|
|
precision Accessor ReadOnly |
DecimalPrecision | FractionalPrecision |
|
|
roundFactor Accessor ReadOnly |
number |
|
|
schemaItemType Readonly |
Format |
|
|
scientificType Accessor ReadOnly |
undefined | ScientificType |
|
|
showSignOption Accessor ReadOnly |
ShowSignOption |
|
|
spacer Accessor ReadOnly |
undefined | string |
|
|
stationOffsetSize Accessor ReadOnly |
undefined | number |
|
|
stationSeparator Accessor ReadOnly |
string |
|
|
thousandSeparator Accessor ReadOnly |
string |
|
|
type Accessor ReadOnly |
FormatType |
|
|
units Accessor ReadOnly |
undefined | [Unit | InvertedUnit, undefined | string][] |
|
|
uomSeparator Accessor ReadOnly |
string |
|
|
Inherited properties
Defined in
Last Updated: 14 November, 2024