InvertedUnit Class
An InvertedUnit is a specific type of Unit that describes the inverse of a single Unit whose dimensional derivation is unit-less.
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): InvertedUnit | ||
fromJSON(invertedUnitProps: InvertedUnitProps): Promise<void> | ||
fromJSONSync(invertedUnitProps: InvertedUnitProps): void | ||
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): InvertedUnitProps | Save this InvertedUnit's properties to an object for serializing to JSON. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective key properties. |
parseFullName(fullName: string): [string, string] Static Inherited | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_invertsUnit Protected | LazyLoadedUnit | undefined | ||
_unitSystem Protected | LazyLoadedUnitSystem | undefined | ||
invertsUnit Accessor ReadOnly | undefined | LazyLoadedUnit | ||
schemaItemType Readonly | InvertedUnit | ||
unitSystem Accessor ReadOnly | undefined | LazyLoadedUnitSystem |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected Inherited | string | undefined | SchemaItem | |
_key Protected Inherited | SchemaItemKey | SchemaItem | |
_label Protected Inherited | string | undefined | SchemaItem | |
description Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
fullName Accessor Inherited ReadOnly | string | SchemaItem | |
key Accessor Inherited ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
name Accessor Inherited ReadOnly | string | SchemaItem | |
schema Readonly Inherited | Schema | SchemaItem |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.