FormatTraits Enumeration
Members
Name |
Value |
Description |
ApplyRounding |
|
Use the rounding factor. Not yet supported |
ExponentOnlyNegative |
|
Indicates that if an exponent value is positive to not include a + . By default a sign, + or - , is always shown. Not yet supported |
FractionDash |
|
Show a dash between whole value and fractional value |
KeepDecimalPoint |
|
Show decimal point when value to right of decimal is empty |
KeepSingleZero |
|
Indicates that the fractional part of the number is required when the fraction is zero |
PrependUnitLabel |
|
Prepend unit label. Not yet supported |
ShowUnitLabel |
|
Append the quantity's unit label |
TrailZeroes |
|
Show trailing zeroes to requested precision. |
Uninitialized |
|
|
Use1000Separator |
|
show a grouping in each group of 1000. |
ZeroEmpty |
|
Zero magnitude returns blank display value |
Defined in
Last Updated: 14 November, 2024