SchemaItemDiagnostic<TYPE extends SchemaItem, ARGS extends any[]> Class
An IDiagnostic implementation used for SchemaItem diagnostics.
Extends
- BaseDiagnostic<TYPE, ARGS>
Extended by
Methods
Name | Description | |
---|---|---|
constructor<TYPE extends SchemaItem, ARGS extends any[]>(ecDefinition: SchemaItem, messageArgs: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): SchemaItemDiagnostic<TYPE, ARGS> | Initializes a new SchemaItemDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
diagnosticType Static | DiagnosticType | ||
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | DiagnosticCategory | BaseDiagnostic<TYPE, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor Abstract Inherited ReadOnly | string | BaseDiagnostic<TYPE, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition Inherited | TYPE | BaseDiagnostic<TYPE, ARGS> | The EC object to associate with the diagnostic. |
ARGS | undefined | BaseDiagnostic<TYPE, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<TYPE, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.