IDiagnostic<TYPE extends AnyECType, ARGS extends any[]> Interface
The interface implemented by all diagnostics used during schema validation.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
category | DiagnosticCategory | The diagnostic category (error, warning, etc...). | |
code | string | The unique string identifier of the diagnostic in the format ' |
|
diagnosticType | DiagnosticType | The context type of diagnostic (schema, schema item, property, etc...). | |
ecDefinition | TYPE | The EC object associated with the diagnostic instance. | |
ARGS | undefined | The arguments used when formatted the diagnostic instance's message. | ||
string | The unformatted message text associated with the diagnostic. | ||
schema | Schema | The schema where the diagnostic originated. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.