ClassDiagnostic<ARGS extends any[]> Class
An IDiagnostic implementation used for ECClass diagnostics.
Extends
- SchemaItemDiagnostic<AnyClass, ARGS>
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(ecClass: AnyClass, messageArgs: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): ClassDiagnostic<ARGS> | Initializes a new ClassDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | DiagnosticCategory | SchemaItemDiagnostic<AnyClass, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor Abstract Inherited ReadOnly | string | SchemaItemDiagnostic<AnyClass, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
diagnosticType Accessor Inherited ReadOnly | DiagnosticType | SchemaItemDiagnostic<AnyClass, ARGS> | Gets the DiagnosticType. |
diagnosticType Static Inherited | DiagnosticType | SchemaItemDiagnostic<AnyClass, ARGS> | |
ecDefinition Inherited | AnyClass | SchemaItemDiagnostic<AnyClass, ARGS> | The EC object to associate with the diagnostic. |
ARGS | undefined | SchemaItemDiagnostic<AnyClass, ARGS> | The arguments used when formatting the diagnostic message. | |
string | SchemaItemDiagnostic<AnyClass, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.