ModifyHandle Class
Classes added to HTMLElements so they can be customized in CSS by applications. A "modify handle" is a visible position on the screen that provides UI to modify a MarkupElement.
Methods
Name | Description | |
---|---|---|
constructor(handles: Handles): ModifyHandle | ||
addTouchPadding(visible: @svgdotjs/svg.js.Element, handles: Handles): @svgdotjs/svg.js.Element | ||
modify(ev: BeButtonEvent): void Abstract | perform the modification given a current mouse position. | |
onClick(_ev: BeButtonEvent): Promise<void> | ||
setMouseHandler(target: @svgdotjs/svg.js.Element): void | ||
setPosition(): void Abstract | set the position for this handle on the screen given the current state of the element | |
startDrag(_ev: BeButtonEvent, makeCopy: booleanfalse): void | the mouse just went down on this handle, begin modification. | |
startModify(makeCopy: boolean): void |
Properties
Name | Type | Description | |
---|---|---|---|
handles | Handles | ||
vbToStartTrn | Transform |
Defined in
- markup/src/SelectTool.ts Line 27
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.