Handles Class
The set of ModifyHandles active. Only applies if there is a single element selected.
Methods
Name | Description | |
---|---|---|
constructor(ss: MarkupSelected, el: @svgdotjs/svg.js.Element): Handles | ||
cancelDrag(): void | called when the reset button is pressed. | |
drag(ev: BeButtonEvent): void | ||
draw(): void | ||
endDrag(undo: UndoManager): EventHandled | complete the modification for the active handle. | |
npcToBox(p: Readonly<WritableXAndY>): Point2d | ||
npcToVb(p: Readonly<WritableXAndY>, result?: Point2d): Point2d | ||
npcToVbArray(pts: Point2d[]): Point2d[] | ||
remove(): void | ||
startDrag(ev: BeButtonEvent): EventHandled | ||
vbToBox(p: Readonly<WritableXAndY>, result?: Point2d): Point2d |
Properties
Name | Type | Description | |
---|---|---|---|
active | ModifyHandle | undefined | ||
dragging | boolean | ||
el | @svgdotjs/svg.js.Element | ||
group | @svgdotjs/svg.js.G | ||
handles Readonly | ModifyHandle[] | ||
npcToVbTrn | Transform | ||
ss | MarkupSelected | ||
vbToBoxTrn | Transform |
Defined in
- markup/src/SelectTool.ts Line 265
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.