LineString3dRangeTreeContext Class
Handler class for searching a range tree containing the segments of a linestring.
- Facilitates multiple searches for closest point and close approach calculations.
Methods
Name | Description | |
---|---|---|
searchForClosestPoint(spacePoint: Point3d, maxDist?: number): undefined | CurveLocationDetail | CurveLocationDetail[] | Search the range tree for closest point(s) to spacePoint. | |
createCapture(points: Point3d[] | LineString3d, maxChildPerNode: number4, maxAppDataPerLeaf: number4): undefined | LineString3dRangeTreeContext Static | Create a range tree context for the polyline points: | |
searchForClosestApproach(contextA: LineString3dRangeTreeContext, contextB: LineString3dRangeTreeContext, maxDist?: number): undefined | CurveLocationDetailPair | CurveLocationDetailPair[] Static | Search the range trees for closest approach(es) between the polylines. |
Properties
Name | Type | Description | |
---|---|---|---|
lineString | LineString3d | Polyline points being searched, indexed by the range tree | |
numPointTest | number | Diagnostic: number of points tested | |
numRangeTestFalse | number | Diagnostic: number of range tests that have returned false | |
numRangeTestTrue | number | Diagnostic: number of range tests that have returned true | |
numSearch | number | Diagnostic: number of searches. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.