CurveLocationDetailPair Class
A pair of CurveLocationDetail.
Methods
Name | Description | |
---|---|---|
constructor(detailA?: CurveLocationDetail, detailB?: CurveLocationDetail): CurveLocationDetailPair | ||
clone(result?: CurveLocationDetailPair): CurveLocationDetailPair | Make a deep copy of this CurveLocationDetailPair | |
swapDetails(): void | Swap the details of A, B | |
tryTransformInPlace(transform: Transform): boolean | Transform the details in place. | |
createCapture(detailA: CurveLocationDetail, detailB: CurveLocationDetail, result?: CurveLocationDetailPair): CurveLocationDetailPair Static | Create a curve detail pair using references to two CurveLocationDetails | |
createCaptureOptionalReverse(detailA: CurveLocationDetail, detailB: CurveLocationDetail, reversed: boolean, result?: CurveLocationDetailPair): CurveLocationDetailPair Static | Create a curve detail pair using references to two CurveLocationDetails. |
Properties
Name | Type | Description | |
---|---|---|---|
approachType | CurveCurveApproachType | undefined | Enumeration of how the detail pairs relate. | |
detailA | CurveLocationDetail | The first of the two details. | |
detailB | CurveLocationDetail | The second of the two details. |
Defined in
- curve/CurveLocationDetail.ts Line 450
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.