AuxChannelDataType Enumeration
The types of data that can be represented by an AuxChannelData. Each type of data contributes differently to the animation applied by an AnalysisStyle and responds differently when the host PolyfaceAuxData is transformed.
Members
Name | Value | Description |
---|---|---|
Distance | Distances in meters used to recolor the Polyface's vertices. When the host Polyface is transformed the Transform's scale is applied to the distances. |
|
Normal | (X, Y, Z) normal vectors that replace the host Polyface's own normals. When the Polyface is transformed the normals are rotated accordingly. |
|
Scalar | General-purpose scalar values like stress, temperature, etc., used to recolor the Polyface's vertices. When the host Polyface is transformed, scalar values remain unmodified. |
|
Vector | (X, Y, Z) displacement vectors added to the Polyface's vertex positions resulting in deformation of the mesh. When the host Polyface is transformed the displacements are rotated and scaled accordingly. |
Defined in
- polyface/AuxData.ts Line 23
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.