AuxChannelData Class
Represents the AuxChannel data at a single input value.
Methods
Name | Description | |
---|---|---|
constructor(input: number, values: Float64Array | number[]): AuxChannelData | Constructor. | |
clone(): AuxChannelData | return a deep copy | |
copyValues(other: AuxChannelData, thisIndex: number, otherIndex: number, blockSize: number): void | Copy blocks of size blockSize from (blocked index) thisIndex in this AuxChannelData to (blockIndex) otherIndex of other |
|
isAlmostEqual(other: AuxChannelData, tol?: number): boolean | toleranced comparison of the input and value fields. |
Properties
Name | Type | Description | |
---|---|---|---|
input | number | The input value for this data. | |
values | number[] | The vertex values for this data. |
Defined in
- polyface/AuxData.ts Line 45
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.