AuxChannel Class
Represents a single PolyfaceAuxData channel.
Methods
Name | Description | |
---|---|---|
constructor(data: AuxChannelData[], dataType: AuxChannelDataType, name?: string, inputName?: string): AuxChannel | Constructor with CAPTURED inputs. | |
clone(): AuxChannel | Return a deep copy. | |
computeDisplacementRange(scale: number1, result?: Range3d): Range3d | Compute the range of this channel's displacement values, if dataType is AuxChannelDataType.Vector. | |
isAlmostEqual(other: AuxChannel, tol?: number): boolean | Toleranced comparison of contents. | |
entriesPerValue(dataType: AuxChannelDataType): number Static | The dimension (1D or 3D) of each datum of an AuxChannel of the given type. | |
isScalar(dataType: AuxChannelDataType): boolean Static | True if the data type is 1-dimensional. |
Properties
Name | Type | Description | |
---|---|---|---|
data | AuxChannelData[] | An array of AuxChannelData that represents the vertex data at one or more input values. | |
dataType | AuxChannelDataType | The type of data stored in this channel. | |
entriesPerValue Accessor ReadOnly | number | The dimension (1D or 3D) of each datum in the data arrays of this AuxChannel. | |
inputName | string | undefined | The input name. | |
isScalar Accessor ReadOnly | boolean | True if the data stored in this AuxChannel is 1-dimensional. | |
name | string | undefined | The channel name. | |
scalarRange Accessor ReadOnly | undefined | Range1d | The minimum and maximum values in data.values , or undefined if isScalar is false. |
|
valueCount Accessor ReadOnly | number | The number of data stored in each data array of this AuxChannel, equal to the length of the array divided by entriesPerValue . |
Defined in
- polyface/AuxData.ts Line 84
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.