AnalysisStyle Class
As part of a DisplayStyleSettings, describes how to animate meshes in the view that have been augmented with PolyfaceAuxData. The style specifies which channels to use, and can deform the meshes by translating vertices and/or recolor vertices using ThematicDisplay.
@see - analysisStyle to define the analysis style for a DisplayStyle.
- analysisFraction to control playback of the animation.
Methods
Name | Description | |
---|---|---|
clone(changedProps: AnalysisStyleProps): AnalysisStyle | Produce a copy of this style identical except for properties explicitly specified by changedProps . |
|
equals(other: AnalysisStyle): boolean | Return true if this style is equivalent to other . |
|
toJSON(): AnalysisStyleProps | Convert this style to its JSON representation. | |
fromJSON(props?: AnalysisStyleProps): AnalysisStyle Static | Create an analysis style from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults Static Readonly | AnalysisStyle | ||
displacement Readonly | AnalysisStyleDisplacement | undefined | ||
normalChannelName Readonly | string | undefined | If defined, the name of the AuxChannel from which to obtain normal vectors for the vertices. | |
thematic Readonly | AnalysisStyleThematic | undefined |
Defined in
- core/common/src/AnalysisStyle.ts Line 203
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.